Rockbox.org home
release
dev builds
extras
themes manual
wiki
device status forums
mailing lists
IRC bugs
patches
dev guide



Rockbox mail archive

Subject: RE: Playlist problem
From: Nielsen Linus (ext) (Linus.Nielsen_at_elema.siemens.se)
Date: 2002-07-31


(First of all, please don't send HTML formatted mails to this list, thanks)

I have changed the MP3 buffer handling and the ID3 info handling quite a lot
recently. But I need the usual vital information:

1) Song length and bitrate
2) Playlist format and lenght, preferably the entire playlist
3) Archos model (Player/Studio/Recorder)
4) Anything else that might be relevant

/Linus

-----Original Message-----
From: Doug [mailto:him10101_at_yahoo.com]
Sent: den 31 juli 2002 07:10
To: rockbox_at_cool.haxx.se
Subject: Re: Playlist problem

Yes, I have the exact same problems, although I don't know about putting
dates on it. Load times and seek-commands are slow, particuarly on
playlists, and I had the same problem with not advancing to the next song,
even when I request "next song". But the problem corrected itself when I
quit the playlist and began it again. To make things unpleasant, it has only
happened once or twice, and certainly not every time I've run playlists.
Other unrelated bugs I just discovered:
1) ID3 info is almost always not displayed when elements are missing (ie
"album"). I found one exception, which I can't understand.
2) I keep getting "End of Song list - Press on to continue" messages when I
run certain songs. This happens with the first 2 consecutive songs in a
directory, and then goes away if I play a different song in that directory
and then try one of the first ones again. (it did happen with the 3rd and
4th songs once but I can't explain it)
-Doug
 Brian King wrote:
I've noticed that somewhere after the 07/22/02 CVS build that playlists
haven't been working very well for me any more. I loaded 07/30/02 on
tonight and found that when I tried to play a playlist that it played
the first song over and over rather than advancing to the next song. I
use playlsts that have entries something like:

../../Tom_Waits/Blue_Valentines/02-Red_Shoes_By_The_Drugstore.mp3

Also, it seems as if the time required to start playing a given song is
longer on builds after 07/22 (I haven't tried every build, that was just
the last build that worked pretty well for me...)

Anyone else see this?

-bk

Do You Yahoo!?
Yahoo! Health - Feel better, live better



Page was last modified "Jan 10 2012" The Rockbox Crew
aaa